Running Clojure applications

You will need to have a Java Runtime Edition (usually installed on most computers by default) to run any Clojure applications.

To test if you have Java on your computer, open a command line window and run the command

java -version

Building Clojure applications

Clojure is a compiled language and as you evaluate your code it is compiled into Java bytecode.

So in order to develop Clojure, you must have either OpenJDK or Oracle SE (JDK) installed, vers 8 is recommended (although version 6 & 7 should work).

javac -version

Installing a Java Software Development Kit (Java SDK)

Download and install the latest Oracle Java SDK (version 1.8 at time of writing).

Alternatively, install OpenJDK

results matching ""

    No results matching ""